Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OpenWebif - New design is broken

Discussion in 'OpenBH General Discussions' started by Tepp, May 11, 2019.

Tags:
  1. Tepp

    Tepp Vu+ Newbie

    Messages:
    13
    Hi,

    The "Old design" is OK, but when switching to "Use new design" option, the Webif become corrupted (see attached screenshot).

    Vu+ Zero4K
    openbh v4.2.018

    BR,

    OpenWebif 001a.png
     
  2. Tepp

    Tepp Vu+ Newbie

    Messages:
    13
    +++

    Tried to update this:
    enigma2-plugin-extensions-openwebif (1.3.0+git3227+2a795af-r0 -> 1.3.0+git3305+4c1f5c8-r0)

    but stuck with this (cannot exit):
    1_0_19_89C_16_70_1680000_0_0_0_20190511154036.jpg
     
    Last edited: May 11, 2019
  3. Tepp

    Tepp Vu+ Newbie

    Messages:
    13
    +++

    OK, after ssh #reboot seems that the Webif terminal is working. But the New design still not.

    Installed:
    • enigma2-plugin-extensions-openwebif (1.3.0+git3305+4c1f5c8-r0)
    • enigma2-plugin-extensions-openwebif-terminal (1.3.0+git3305+4c1f5c8-r0)
     
    Last edited: May 11, 2019
  4. nunigaia

    nunigaia Moderator

    Messages:
    4,916
    It seems you are at Open BlackHole 4.2.018 ... the lastest version is Open BlackHole 4.2.041.

    1) Do an "ONLINE update"

    1.1) Using your RCU

    1.2) By telnet, using the following commands:

    Code:
    
    opkg update && opkg upgrade
    reboot
    
    
    2) You need to install also themes:

    By telnet:

    Code:
    
    opkg install enigma2-plugin-extensions-openwebif-themes
    killall -9 enigma2
    
    
    Then you must be able to change to OpenWebIf new design.

    best regards
    nunigaia
     
  5. Tepp

    Tepp Vu+ Newbie

    Messages:
    13
    Thank you for quick reply.

    Yes, Open BlackHole 4.2.018 which is the latest available here:
    https://www.vuplus-community.net/board/threads/openbh-4-2-vu-zero4k.37393/

    Not tried to upgrade from GUI, also because:
    1. it works fine as it is now
    2. did not see any release notes or change log
    3. don't know how to backup and restore in case of problems (don't want to re-configure from scratch)

    will try to install themes first.
     
  6. nunigaia

    nunigaia Moderator

    Messages:
    4,916
    Is up to you, try to install themes, 2nd point on my reply to your post at --> https://www.vuplus-community.net/board/threads/openwebif-new-design-is-broken.39152/#post-260052

    Note: If you are at 4.2.018 version, you can securely update your stb. In any case, you can previously run a Full Backup of your image, before update it :). If something goes wrong you can allways draw back.

    best regards
    nunigaia
     

Share This Page